Difference in Vulnerability – PSAT (Educate)

QuestionI see two endpoints: one with IE8 and one with IE9. One of the endpoints is running a plugin that is a newer version than the other. Yet the older version is shown as not vulnerable, and the newer version shows as vulnerable. Why?

AnswerPlugin versions differ between browsers and between operating systems. For example, the current version of Adobe Flash will differ between Firefox on Windows, Linux, and OS X. In the case above, the lower version number on IE8 was found to be the most up to date version on that specific platform.

See also Endpoint Vulnerability Check, Showing Acrobat as Vulnerable, and Browser Fingerprinting for additional information.